navbar

ISDN Configuration Explanation and Example


Q: I was wondering if anyone has any information on ISDN, how it works and how the 3000 platform handles it. Also, any configuration information would be helpful.

A: The following is an example of a 3103 (1E/1BRI) router. I will also put some comments in the configuration.

This router is connected to a Northern Telecom DMS-100 switch. The SPIDs for this station are 415988488501 and 415988488602. These numbers were configured on the switch and would be given to you by the telephone company. 9884885 and 9884886 are regular phone numbers for the two channels. The isdn spid1 and isdn spid2 commands are not required for an AT&T switch.

The next required command is the dialer-group 1, but the number "1" could be any number from 1-99. This defines "interesting" packet types. An interesting packet is a packet that will activate the dialing sequence and will reset the "idle-timeout" timer. This can be done by defining an access-list and tying the access-list to a dialer-group using the dialer X list Y command -- where X is the dialer-group's number, and Y is the access-list number. Here's how to tie these commands together:

  interface BRI 0
  dialer-group 1    
  !
  access-list 101 permit icmp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
  access-list 101 permit tcp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
  access-list 101 permit udp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
  dialer-list 1 LIST 101

In this example, the interface BRI 0 is defined to be in dialer-group 1. Any ICMPs, TCPs, and UDPs going out of the BRI interface will activate the dialing sequence.

The next thing to do is to map between the next-hop address and the phone number that the router would dial to. This can be done by using dialer map ip command. This command is not necessary if you will dial to only one router. If you don't use the dialer map ip command, you will have to use dialer-string. The following example configuration uses both commands.

An important note: If you want to have multiple routers call each other, you would have to use PPP encapsulation with CHAP authentication on the line. This is recommended so that the routers would be able to know which routers they talk to at any time. The required configuration for this part is as follows:

  interface BRI 0
  encapsulation PPP
  ip address 131.108.157.2 255.255.255.0
  ppp authenticate chap
  dialer map ip 131.108.157.1 name isdn2 4883 !
  username isdn2 password stanFord

In this example, we use PPP with CHAP, and the remote router that we will talk to is 131.108.157.1. The remote router's name is "isdn2". The secret word between the two routers is "stanFord". In the real configuration on the router, the secret word "stanFord" will be encrypted. You will have to define (assume that this router is "isnd1") "username isdn1 password stanFord" in the remote router. The phone number of the "isdn2" router is 4883. If you don't want this router to dial out, you could put the following command:

  dialer map ip 131.108.157.1 name isdn2

Full Configuration

version 9.1
!
hostname isdn1
!
enable-password XX
service tcp-keepalives-out
service timestamps
!
boot system flash
!
!
buffers middle max-free 100
!
!
!
!
!
!
isdn switch-type basic-dms100
!
interface Ethernet 0
ip address 131.108.64.190 255.255.255.0
no mop enabled
!
interface BRI 0
encapsulation PPP
ip address 131.108.157.2 255.255.255.0
isdn spid1 415988488501 9884885
isdn spid2 415988488602 9884886
ppp authenticate chap
dialer idle-timeout 300
dialer string 4883
dialer map IP 131.108.157.1 name isdn2 4883 dialer-group 1
!
!
router ospf 1
network 131.108.64.0 0.0.0.255 area 0.0.0.0 !
router igrp 109
distribute-list 10 in
network 131.108.0.0
neighbor 131.108.157.1
passive-interface BRI0
!
ip route 131.108.0.0 255.255.0.0 131.108.19.0 
ip route 131.108.19.0 255.255.255.0 131.108.64.1 
!
!
!
!
!
!
access-list 1 permit 192.0.254.0 0.0.0.255 
access-list 1 permit 131.108.0.0 0.0.255.255 
access-list 10 permit 131.108.128.0 0.0.127.0 
access-list 101 permit icmp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 
access-list 101 permit tcp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 
access-list 101 permit udp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 
dialer-list 1 LIST 101
banner motd
Please shut int B 0 off when not in-use. 

username isdn1 password 7 11120F175804
username isdn2 password 7 02450D480A09
!
!
line vty 0 4
login
line con 0
exec-timeout 0 0
line aux 0
no exec
line vty 0
exec-timeout 0 0
password XX
line vty 1
exec-timeout 0 0
password XX
line vty 2
exec-timeout 0 0
password XX
line vty 3
exec-timeout 0 0
password XX
line vty 4
exec-timeout 0 0
password XX
!
end


Posted: Tue Oct 10 13:42:55 PDT 1995
Copyright 1996 ©Cisco Systems Inc.